centos vi命令的用法

centos vi命令的用法
vi编辑器是所有Unix及Linux系统下标准的编辑器,它的强大不逊色于任何最新的文本编辑器,这里只是简单地介绍一下它的用法和一小部分 指令。由于对Unix及Linux系统的任何版本,vi编辑器是完全相同的,因此您可以在其他任何介绍vi的地方进一步了解它。Vi也是Linux中最基 本的文本编辑器,学会它后,您将在Linux的世界里畅行无阻。 1、vi的基本概念   基本上vi可以分为三种状态,分别是命令模式(command m...

Windows 2003/IIS虚拟主机实现301跳转

Windows 2003/IIS虚拟主机实现301跳转
Windows 2003/IIS虚拟主机的301跳转一直是一个很让人头疼的难题。Apache下可以通过.htaccess轻松实现的跳转,到了IIS下,真的是让人很不爽。 百度搜了很多方法,失灵时不灵。研究了很久总算找到了一个用rewrite组件来实现301跳转的方法,总之小侯的zzcto网站测试成功。但不保证对所有IIS虚拟主机100%有效。 想要通过此方法实现Windows 2003/IIS虚拟主机的301,首先你要确认你的主机满足以下需求: 1、虚拟...

FTP530错误,连接FTP提示530 User xxx cannot log in.的解决办法

FTP530错误,连接FTP提示530 User xxx cannot log in.的解决办法
FTP530错误,一般情况下出现在服务器使用者利用FTP软件连接服务器的FTP的时候。 具体错误代码: [R] 331 Password required for xxx. [R] PASS(hidden) [R] 530 User xxx cannot log in. //xxx是FTP帐号,具体显示以你自己的FTP帐号为准 从错误代码上看,530错误就是100%的FTP帐号或密码错误。 一般情况下通过修改FTP密码,就可以正常链接。 但是遇到特殊情况的时候,修改密码还是不行。以小侯这边的经...

织梦DedeCMS网站被挂马后解决方案

织梦DedeCMS网站被挂马后解决方案
DedeCMS做的网站被挂马了,真要找哪个文件被修改了,哪里藏有木马文件,可能比较麻烦。建议大家备份数据,重新安装dedecms系统,并还原数据,然后做好安全设置,以防再次被挂。 可以按照如下步骤解决: 1、后台备份数据,备份成功后打包整个网站数据,下载到本地电脑。切记! 2、安装全新的dedecms系统,安装完成后,登录后台。 3、上传备份数据文件夹/data/backupdata,覆盖到相应的目录。 4、后台-恢复还...

2013织梦DedeCMS被挂马特征汇总

2013织梦DedeCMS被挂马特征汇总
一、织梦CMS被挂马特征汇总 2013织梦CMS被挂马特征汇总。最近很多朋友反应后台多了几个系统管理员用户:service、spider等,而且自己之前的管理员用户登陆时候会提示用户名不存在。还有朋友的织梦CMS网站里出现asdd、90sec、service等PHP格式的非DedeCMS源文件,这些木马文件内容一般为 等等,被挂马后网站根目录下会生成一堆赌博网页等。 二、织梦CMS被挂马清理方法 1、删除增加的管理员service、spider...

织梦dedecms漏洞防护

织梦dedecms漏洞防护
近期稳网互联技术人员监控发现大量dedecms搭建的网站因为dedecms漏洞被黑,程序被恶意删除,添加黑链,被挂马,对外做攻击等严重程序安全问题. 强烈建议所有使用dedecms程序的客户务必对程序进行升级,并按照dedecms后台的安全提示对目录进行设置,dedecms漏洞严重,会导致程序被黑客入侵,删除,严重后果.希望各位使用dedecms的客户务必重视.并及时更新最新版程序.并升级最新补丁包. dedecms官方补丁下载地址→传送...

织梦(DedeCMS)后台提示“DedeTag Engine Create File False”

织梦(DedeCMS)后台提示“DedeTag Engine Create File False”
织梦程序(DedeCMS)后台更新提示这个提示DedeTag Engine Create File False。一般出现以下情况才会出现: 1.模板文件不存在,您可能误删除或者没有正确指定模板文件; 2.模板文件没有读取权限,按照织梦程序包中的readme文档要求,设置读写权限。 近期织梦经常爆出各种安全漏洞,导致的问题也多种多样。有被挂黑链的,有被泛解析的,也有对外攻击的。所以各位亲,珍爱网站远离织梦。 使用稳网互联台湾虚拟主...

Mysql version can not be less than 4.1.PHPweb

Mysql version can not be less than 4.1.PHPweb
今天偶然遇到一个老客户到处求助,客户租用的台湾服务器中,在服务器中转移一个phpweb程序做的企业站的时候,出现了一些问题.文件和数据库都已经导入并且配置好了.但是访问网站却提示Mysql version can not be less than 4.1.这个提示很有意思,因为客户的服务器配置我是很明白的,php版本是5.3,MySQL版本是5.0.但是网站提示的意思却是mysql版本不能低于4.1. 初步我觉得可能是程序的问题,于是借来客户的程序备份...

Access错误原因:未知错误ID:-2147467259 操作必须使用一个可更新的查询

Access错误原因:未知错误ID:-2147467259 操作必须使用一个可更新的查询
昨天一个使用Z-blog的台湾空间客户更新文章时出现的这个错误提示. 错误原因:未知错误ID:-2147467259。 摘要: 操作必须使用一个可更新的查询。 Microsoft JET Database Engine 如图: 似乎Z-blog和大部分ASP+Access的程序,都会时不时的遇到这种问题,其实很多ACCESS数据库类网站出现这种问题都可以用这种方法试试,方法其实很简单,只是一种思路。 错误原因 问题应该是服务器数据库目录的写入权限没有设置好,...